metal incentives not showing.friday afternoon

money time

Well-Known Member
Great. Friday afternoon. Platinum is 2x but rides not showing any multiplier and now i need to email this f'd up csr for all those rides and explain them . How long will this take. Such a mess already 5 rides .just now noticed.
 

uberray25

Active Member
Same here. No boost added to my trips. I can just imagine CSR reply to my email. What a joke.
It shows multiplier on the map but not added to the trip.
 

Bangle44

Well-Known Member
My last three rides and 4 of 7 not showing boost. Hate to drive for peanuts and hope for reimbursement... But I will. Need the ride count.
 

Nikko

Member
Jeez. I can't risk the rage of not getting the boost later. But I would think they can't screw over that many people at once. I should just go drive. This company really sucks.
 

hy1368

Well-Known Member
So did the problem get fixed this morning?Are boots are applied to the pings now?Are you guys recieving the boots today?
 

money time

Well-Known Member
  • Thread Starter Thread Starter
  • #17
So did the problem get fixed this morning?Are boots are applied to the pings now?Are you guys recieving the boots today?
Problem was fixed yesterday
I have about 8 rides needed adjusyments. They will not do it automatically.
Lets go emails.....
 

Bangle44

Well-Known Member
You can tell in the ping if the boost multiplier will be applied or not. No boost, no accept. I had 10 non-core rides yesterday and they all got the boost (despite it not showing on the map). I had 6 in the core and 5 did not get the boost. From yesterday.
 
Top