Jetta Warning Lights

Rooster06

Well-Known Member
Background: I have a 2011 Jetta 2.5 SE Manual; it just hit 201,000 miles; I do most of my own maintenance; and I got an oil change yesterday.

Problem: After ubering around Denver today (great day, hit my goal in about 5 hours) and on the way home; I feel a drop in power, the engine starts feeling rough; then the CEL starts blinking and the EPC light comes on solid. I pull off at the next exit and check the manual. Both warnings say to ease of the accelerator and drive to the nearest dealer. The CEL blinking indicates a possible missfire or potential catalytic converter failure. The EPC idicates missfire or other power/fuel/ignition issue. After I decided to drive to a safe parking spot, the CEL came on solid, which idicates a catalytic converter malfunction/failure.

The VW forums range in answers from spark/coil issues all the way to blown out cylinders, or brake vacuum pump failures... thereby giving no real answers.

Questions:
Does anyone here have experience like this in a Mk VI Jetta, and if so, what was the result?
Do you think it's safe to drive to the closest dealership (16 miles, but not prefered)?
Is it safe to drive to the better dealership (35 miles, but awesome service department)?

And no, I do not have any diagnostic codes. And the very few independent mechanics locally who will work on VWs are just as, if not more expnsive than the dealership...

And GO!
 

Adieu

Well-Known Member
Spend $12 on Amazon, get a chinese ELM327... works with bluetooth phones, get Torque Lite for Android dunno what for apple

Panlong is a decent ELM 327 knockoff brand that still works like 2 years later, for 12 bucks that's extremely high praise

PS if you got airbag lights need clearing, diagnostics of vw specific non-OBD things, or have diesel and need diesel codes, then get a VW-specific reader
 

Rooster06

Well-Known Member
I do have an airbag light that won't clear, and a light bulb warning light. Dealer couldn't figure those ones out. Problem is, the car is parked at a local gas station, and can't sit until I order a code reader and have it delivered. There is an auto zone up the street about a 1/4 mile from the gas station. Maybe I'll take it there first.
 

Rooster06

Well-Known Member
While I don't disagree, I was hoping to get that thing to 300k. Just to say that I did. No problems at all up until now...

I should say no major problems...
 

ReyesMX6

Active Member
Curious, does the car still run but won't accelerate quickly or above a particular speed, usually pretty slow and no higher than 35MPH ?

The issue sounds like something to do with ignition, spark plug, wires or coils. I'm not familiar with the VW Jetta but I believe it has COP (coil over plug), so there are no real spark plug wires. The wire harness plugs into the coil plug which connects directly to the spark plug itself. I would check each connection (2.5 is a 4 cylinder so you will have 4) and ensure you don't have a broken connection. Plastic tends to get brittle over the years, and with the constant heating and cooling of the engine compartment, so it's possible for one to crack and result in a poor connection. If the connections seem secure and are not broken the next step is to check for a bad coil plug, which is fairly easy. Start the car and unplug each coil plug from the spark plug, individually one by one-then plug back in, looking for the engine to bog down. If you unplug one and the engine doesn't bog down then that one obviously isn't working and needs to be replaced.

If you are worried it is the catalytic converter the easy check is to start the car and look for exhaust to be coming out of the vehicle. If the exhaust is coming out then the converter is probably not an issue, but if you don't feel any exhaust you have a clogged converter. However, typically the car will not run when the converter is clogged (Update: Also, if the car is hot look under the car and see if the converter looks like a red delicious apple. They will get bright red when they are going bad due to excessive heat) . A partially clogged converter will still allow a car to run, but you usually get an O2 sensor code, not one saying the converter is actually bad.

Hopefully this makes sense to you, but it may not be your issue at all. I once drove a Scion XA that had this same condition though and that was the issue. A trip to NAPA for the OE coil plug fixed it in 5 min. Engine mechanics are basically the same, its just the name that changes...well in most cases.
 
Last edited:
Top